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1 ISM Introduction
1.1 OverView

Welcome to use InHand Industrial Ethernet Switch (For Short InSwitch) series product.
ISM series switches provide a robust, easy to use and secure switching infrastructure
for harsh environments. InSwitch series of industrial design, in line with industry
norms; its tools to simplify the industrial network deployment, management and
replacement; and based on open standards to provide a good network security. ISM
series are idea productsl for industrial Ethernet applications, including wind power,
distribution automation, substation, factory automation, intelligent transportation

systems (ITS) and other deployments in harsh environments..

1.2 Product Features

> Fast redundant ring network technology to protect critical network:

InSwitches build fast redundant fiber ring network, based on ITU-T G.8032
protocol, high compatibility, interoperable with other proprietary ring protocol
device. Support the single ring, the intersection ring, tangent ring and other
complex topologies. Fast self-healing function, the ring recovery time<5ms
» Quality of Service(QoS), intelligent control multi-service traffic
For some network applications, such as real-time control and VoIP, Ethernet
frames need to predict the arrival time. Switch due to its frame-based buffer queue
and a first-processing mechanism, the network load will produce a larger delay.
QoS allows the time-sensitive data raised to the front of the queue to reduce
latency and jitter, thus ensuring the normal operation of these applications.
» VLAN(EEE 802.1q) Simplifies network planning
Virtual LAN(VLAN) can separated a physical network to a logical network which
has multiple independent broadcast domains. As the host can only access other

hosts in the same VLAN and isolate the broadcast storm, thus VLAN provides a

5
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measure of security. InSwitch support port-based VLAN, IEEE 802.1q and GVRP

protocol to exchange information in order to ensure consistency of network VLAN.
» Simple Network Management Protocol(SNMP), allowed integrated

management

SNMP provides a standard way for network management, it can query different
vendors’ equipment. InSwitch supports SNMP version V1, V2C and V3. SNMP
V3 has security features such as authentication, privacy and access control.
InSwitch also support many of the MIB, to facilitate the network management
system with any (NMS) integration.
> RMON(Remote Network Monitoring)
RMON is an Internet Engineering Task Force(IETF) standard monitoring
specification that allows different networks to exchange media and control system
status information. RMON gives you a comprehensive network fault diagnosis,
planning, performance analysis, and prophecy.
» IGMP Snooping and GMRP
InSwitch uses IGMP snooping (Internet multicast management protocol v1, v2 and
v3) to intelligently forward or filter multicast network in the host data stream (eg
MPEG video). This data can be transmitted directly to the needs of terminal
equipment, and reduce the Ethernet traffic.
> Broadcast storm suppression network to prevent storm disaster
Broadcast storm caused severe damage and lead to failure of the network all
connected devices. In the business-critical applications, it may bring catastrophic
losses. InSwitch filtering based on user-defined limits to suppress broadcast

packets broadcast storms.

2 Access InSwitch

In this Chapter, we will introduce the way of accessing InSwitch. There are four ways
of setting configuration interface when you want to access InSwitch: web explorer,

serial port, telnet and SSH. If you don’t know InSwitch’s IP address, you could choose
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serial port configuration by using serial port line to connect InSwitch and PC’s COM

port. In addition, telnet and web explorer are based on LAN or Internet.

This chapter mainly includes the flowing parts:
e  Web Explore Configuration

e Serial Port Configuration

e Telnet Configuration

e SSH Configuration

@ Attention

InSwitch support Web, serial, telnet and SSH, but we suggest you not to use multiple

kinds of connection ways, thus you can effectively configure Inswitch .

2.1 Web Explorer Configuration

The default IP address of InSwitch is http://192.168.2.2. Please set your PC’s IP
address and ensure that PC’s IP and InSwitch’s IP are in the same network segment.
The settings are as below (Based on the Windows operation system):

1) Open “Control Panel”, double click “Network Connections” icon, and enter
“Network Connections” Screen.

2) Double click “Local Area Connection”, enter “Local Area Connection Status”

screen:

-4 Local Area Connection Status

General | Support|
Connection
Status: Connected
Duration: 01812
Speed: 1.0 Gbps
Activity
Sent — ?Tj —— Received
—h
Bytes: 33920 | 107.297
[Propellies ][ Disable ]

3) Click “Properties”, enter “Local Area Connection Properties” screen:
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-+ Local Area Connection Properties

General | Advanced |

Connect using:
l- YhMware Accelerated AMD PCNet Ad |[ Corigaen. |

This connection uses the following items:

VI B Client for Microsoft Networks
File and Printer Sharing for Microsoft Networks
QoS Packet Scheduler

= Intemet Protocol (TCP/IP)
Description

Transmission Control Protocol/Internet Protocol. The default
wide area network protocol that provides communication
across diverse interconnected networks.

[[] Show icon in notification area when connected
[¥] Notify me when this connection has limited or no connectivity

—

ok |[ cancel |

Choose “Internet Protocol (TCP/IP)”, click “properties” button, set your PC in the
subnet: 192.168.2.0/24, for example, set IP: 192.168.2.10, Net Mask:
255.255.255.0, Default Gateway: 192.168.2.2

Internet Protocol (TCP/IP) Properties Eﬁgl

General
‘You can get IP settings assigned automatically if your network supports
this capability. Otherwise, you need to ask your network administrator for
the appropriate IP settings.
(O Obtain an IP address automatically
(&) Use the following P address:
P address: 192 .168. 2 . 10
Subnet mask: 265.265.255. 0
Default gateway: 192 .168. 2 . 2
Obtain DNS server address automatically
(3) Use the following DNS server addresses:
Prefened DNS server: 8.8 .8 .8
- ——
Advanced...

Click “OK”.
After configure TCP/IP protocols, you can use ping command to check whether the
link between PC and Router is built correctly. There is an example to execute Ping

command under Windows XP as below:

Ping 192.168.2.1
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If the screen shows:

Microsoft Windows XP [Version 5.1.26001]
(C> Copyright 1985-28081 Microsoft Corp.

:\Documents and Settings\inhand>ping 192.168.2.2

Pinging 192.168.2.2 with 32 bytes of data:

Reply from 192.168.2.2: bhytes=32 time=1ms TTL=128
Reply from 192.168.2.2: hytes=32 time=1ms TTL=128
Reply from 192.168.2.2: bhytes=32 time=1ms TTIL=128
Reply from 192.168.2.2: bytes=32 time<{ims TTL=128

Ping statistics for 192.168.2.2:
Packets: Sent = 4, Received = 4, Lost = @ (Bxz loss).
pproximate round trip times in milli-seconds:
Minimum = Bms, Maximum = 1ms, Average = Bms

C:\Documents and Settings\inhand>ping 192.168.2.2

Then the link between the PC and Router is correct connected. Else if it shows:

Microsoft Windows XP [Uersion 5.1.26001]1
(C)> Copyright 1985-28081 Microsoft Corp.

C:\Documents and Settings\inhand>ping 192.168.2.2
Pinging 192.168.2.2 with 32 bhytes of data:

timed out.
timed out.
out.
out.

Ping statistics for 192.168.2.2:
Packets: Sent = 4, Received 4 <1088x loss>.

C:\Documents and Settings\inhand>

Then the connection seems not build, and you need to check thoroughly following the

former instructions.

After finishing the configuration above, you could set your InSwitch:

Open IE browser, input the default IP address of the Switch: http://192.168.2.2, you

can see the login web below:

(02) 8283 7444
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Authentication Required

The server 192,168.2.2:80 requires a username and password.
The server says: welcome to InSwitch.

User Name: |

Password: I

[ togin || cancel |

Input “username”’(default: adm) and the “password” (default: 123456), and then click

“login” to enter the operation screen.

2.2 Serial Port Configuration

Before using Serial Port to login InSwitch, please connect InSwitch’s RS-232 console
port to PC’s COM port through serial port line. Please refer to the following steps and

set Windows XP hyper terminal to login serial port console.

1) Windows desktop, click “Start up” -> “All Applications” -> “Attachment” ->

“Communication” -> “Hyper Terminal”.

— T T e

@ Windows Update

es » @ Accessibility
N @) Games » || @) Entertainment
@ Google Chrome: @ Google Chrome | i) System Tools
]_(\jL E-mail @ Microsoft OFffice » |} ') Address Book
~ Microsoft Office Outiff
- oSO S ) startup | S caleulator
o= WIinRAR » Command Prol
(’g Microsoft Office Wor| @ = gt
= PN Adobe Reader X W Notepad
v MSN @ Internet Explorer Y Paint
we msn @) Program Compatibility Wizard
® Windows Media Playdl (G) Outlook Express (s Remote Desktop Connection
) w Remote Assistance g Synchronize
hak e Windows Media Player & Tour Windows XP
\Windows Messenger 3 ‘Windows Messenger 3 Windows Explorer
“
@) Windows Movie Maker A wordpad
1\@ Tour Windows XP @ Adobe LiveCycle ES2 | i Communications »| ® HyperTerminal
B8 Adobe Acrobat Distiller X & Network Connections
E- Adobe Acrobat X Pro 9 Network Setup Wizard

New Connection Wizard
<2 wireless Network Setup Wizard

o I Turn Off Computer

74 start *s Network Connections k- Local Area Connectio. ., i 1-Paint @) HyperTerminal

2) Input the connection describing, for example “InSwitch”, then click “OK”.
10
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Connection Description

Enter a name and choose an icon for the connection:

Name:
| InSwitch |

TLITE

[ ok || cancel |

3) Choose COM port which is used in connecting Switch, then click “OK”. (The

COM port number is up to your computer’s system setting.)

Connect To @

% InSwitch

Enter details for the phone number that you want to dial:

Country/region: =12 [55)

—

Phone number: I ]

Connect using: TR ~ |

[ ok | [ Cancel ]

4) Set connection value, then click “OK”.

11
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COM1 Properties Elgl

Port Settings |

Bits per second: | 115200 v/
Data bits: | 8 v
Paiity: | None M

Stop bits: | 1 v/

Flow control: | [NGIE

Restore Defaults

ok J[ cencel J[ aeoy |

Bits per second: 115200 baud rate as default
Data bit: 8 bits as default
Parity check: none as default
Stop bit: 1 bit as default
Data flow control: none as default
5) Input username and password in the hyper terminal window. The default username

and password of InSwitch are adm/123456. Then you will login serial port console.

12
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£

& InSwitch - HyperTerminal EJ@|
File Edt View Call Transfer Help

N 38 0 &

InSwitch login: adm
IPassword:

Welcome to InSwitch console

Copyright (c)2001-2011 Beijing InHand Networks Co., Ltd.
http://www.1inhand.com.cn

Hodel : ISM2009
Serial Number : SM2091104001048
Current Version :1.0.0.r2601

Current Bootloader Version : 1.1.6.r2130

06:44:14 InSwitch>

Connected 0:00:06 Auto detect Auto detect SCROLL CAPS NUM Capture Print echo

2.3 Telnet Configuration

Please follow steps as below:
1) Click “Start” -> “Run”, then input InSwitch IP address that you want to connect.

Run E|

- Type the name of a program, folder, document, or
3 Internet resource, and Windows will open it for you.

S clret 192.165.2.2 v

[ o ” Cancel ][ Browse... ]

You could also input telnet command in MS-DOS.

13
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INDOWS\system32\cmd.exe

Microsoft Windows XP [UVersion 5.1.26001]
(C> Copyright 1985-20801 Microsoft Corp.

:\Documents and Settings\Administrator>telnet 192.168.2.2_

2) After enter command prompt, input username and password (adm/123456 as

default) to login InSwitch telnet console interface.

cv Telnet 192.168.2.2

InSwitch login: adm
Password:

T 0T I 0 T I 20 200 000000020 0 2020200020 0 00 0 0D 2 0 00 0 00 - 2 2 D D 2 D - D
Welcome to InSwitch console

Copyright <(c>2801-2011 Beijing InHand Networks Co..
http://www.inhand.com.cn

odel 1SM2009
iSerial Number SM2P91184001848

[ICurrent Uersion r2601
Current Bootloader 1.1.6.»2130

B6:34:47 InSwitch> _

14
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2.4 SSH Configuration

Please follow steps as below:

1) Login the Switch through Web Explorer, for example IE browser. Then enable
SSH server function (refer to configure SSH server).

2) Using SSH Client to login Switch. Take PuTTY as example (PuTTY is a remote
tools for free, it supports Telnet, SSH, rlogin protocols, in this case we will take
Release 0.61 version). Open PuTTY, click “Session” in the categories, set

configurations as picture below.

15
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g,c‘ PulTY Configuration
Category:
= Session Basic options foryour PuTTY session
Lo.g ging Specify the destination you want to connectto
= Terminal - -
Keyboard Host Name (or IP address) Port
Bell 192.168.2.2 22
: WinI;e;:Jres Cannection type: ) ) i
(JRaw () Telnet ()Rlogin ®SSH () Serial
Appearance
Behaviour Load, save or delete a stored session
Translation o 4 Sossi
Selection ave! essions
Colours
- Connection .
Default Settings -
Dete . [_toed |
Proxy [
Telnet Seye
+# SSH
Serial
CJDSE window on exit: )
() Always () Never (@) Only on clean exit
|

After setting, click “Open”, you will see the dialog box as below, input username and
password (adm/123456 as default). Then, you will enter Switch console interface.

InSwitch login: adm
assword:
Welcome to InSwitch console

Copyright (c>2001-2811 Beijing InHand Networks Co., Ltd.
http://uwwu.inhand.com.cn

: I1SM28089
Berial Number : SM20911084001048

urrent Uersion : 1.0.8.»2601
urrent Bootloader Uersion : 1.1.6.»2130

6:34:47 InSwitch> _

16
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3 Web Configuration

3.1 Administration
This chapter introduce system management, Administration settings include the 10
settings: system, networks, system time, admin access, config management, SNMP,

alarm, log, upgrade, reboot.

3.1.1 System

In the “System Status” web, you can check system’s basic information and running
status information.
In the “Basic Settings” web, you can set system’s basic configuration, including system

language and host name. .

3.1.1.1 System Staus

Click “configuration->system” in the navigation bar, enter “system status” web.

= .
& Administration >> System
fpanc Systom| (7]

Administration »
Ports 5 Name InSwitch
i Model ISM2008
Virtual LANS ' | MAC Address 0018,05a0,002d
Redundancy » | Curent Version 1,0,0.12601
Security » Current Bootloader Version 1.1.8.12130
QoS »
Switch Time 2000-01-07 01:02:43
pulticastEieting BBl pc Time 2011-09-28 11:02:56
mflie?dﬂms Y| Uptime 0 day, 00:25:07
CPU Load (1/5/ 15 mins) 0,00/ 0.00/ 0.00
'}";’:ﬁ;fe‘;"”sum"m 60,16MB / 27.31MB (45.35%)
343 s [+ Stop
Page information description is as shown in the following table.
Parameters Name Description Default
Name Switch host name none
Model Switch model none
Serial NO. Switch serial number none
MAC address Switch MAC address() none
Current version Switch firmware number none
Current Bootloader Switch bootloader version number none
17
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version

Switch time Switch system time none

Host time Visit host system time through web none
interface

Start time Running time from start to current none

CPU load (1/5/15 CPU average load none

minutes)

Memory gross/remaining | Switch gross memory and remaining none
memory

3.1.1.2  Basic Setup

Click “management-> system” in the navigation bar, then enter “Basic Setup”

interface.
o]

he Administration >> System

Hpnand (| Bt o
Administration 4
Ports , | Lansuage English[~]
Vitual LANS y | Switch Name AL
Redundancy »
Security »
QoS »
Multicast Filtering »
MAC Address »
Tables

Page information description is as shown in the following table.

Name Description ‘ Default
language Switch system language English
Switch Name Switch host name InSwitch

3.1.2 Networks

In the “Networks” interfaces, you can configure switch’s IP address and gateway,
configure DNS server.

In the “SSH server” interfaces, you can configure SSH server’s parameters.

18
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3.1.2.1  Configure Networks

Click “management->networks” in the navigation bar, then enter “networks interface”.

-
€ Administration >> Networks
fpend (Wetworks] (1]

Administration 12
Ports » | IP Address 192.168.2.2
Virtual LANS , | Netmask 255.256.256.0
Redundancy , | Gateway
Security > | bNs
QoS >
5 No. DNS
Multicast Filtering [ Jeooo
MAC Address >
Tables

Page information description is as shown in the following table.

Name Description ‘ Default
IP address Switch IP address 192.168.2.2
Subnet Mask Switch subnet mask 255.255.255.0
Gateway Default gateway None
DNS DNS server’s IP address, you can none
input 6 DNS server at most

[3 Instruction
When fill multiple DNS, system will poll all the DNS server, until find available DNS

Server.

3.1.2.2  Configure SSH Server

Click “management->networks” in the navigation bar, then enter “SSH server”

interface.
o]
.(x| ] Administration >> Networks :

Administration »
Ports » SSH Status ﬂ
Virtual LANs 7 i

Key Length 1024~
Redundancy L2 —_—

Timeout 120 s(0-120)
Security »
Qo8 » niilibiwidiiirt

Apply & Save Cancel

Multicast Filtering > (ton & 5o il
MAC Address »
Tables

19
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Name Description ‘ Default
SSH status Enable or disable SSH server Disable
Code mode Set PKI encryption mode(only RSA
support RSA)
Length o fkey Set length of key, it could be 512 or None
1024
overtime SSH overtime, SSH server will be 120

disconnected when the server client

has no operation.

3.1.3 System Time

3.1.3.1

Configure System Time

Click “management->system time” in the navigation bar, enter “system time” interface.

Then button “synchronous time ” will help user synchronize switch system time with

host time. Configure parameter in the box “Year/Month/Date”, “Hour:Min:Sec”. Then

click “Apply”.

Administration
Ports

Virtual LANs
Redundancy
Security

QoS

Multicast Filtering

MAC Address
Tables

Administration >> System Time

(Sytam T (10
Switch Time 2000-01-07 01:20:29
PC Time 2011-09-28 11:20:42
Year/Month/Date 2000[=] / [01[=] /[07[]
Hour:Min:Sec [01]7]: i [28[=]
Apply
Timezone ‘UTC‘HJB:I]U China, Hong Kong, Western Australia, Singapore, Taiwan, REIIEI

J‘ Apply & EEVew
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Page information description is as shown in the following table.

Name Description ‘ Default
Switch time Switch system time none
Host time Visit switch’s host system time none
through web interface
Year/Month/Day Year, Month, Day part of time Current year, month, day

Hour:Minute:Second

Hour, Minute, second part of time

Current hour, minute,

second

Time zone

UTC+08:00

System time zone

3.1.3.2  SNTP Client

Click “management->system time” in the navigation, then enter “SNTP Client”

interface.
)
L Administration >> System Time
Hphand (| e e
Administration ]
Ports , | SNTP-Client @E{
Virtual LANS , | Update interval 3600 s(60-3600)
Redundancy * | SNTP Servers List
Security 3
Server Address Port
QoS >
0.0.0.0 123
Multicast Filtering » m
MAC Address > -
Tables
,

Page information description is as shown in the following table.

Name Description ‘ Default
SNTP Client Enable or disable SNTP Client disable
Update Interval The interval between switch and | 3600
SNTP Server synchronous time
SNTP Servers list SNTP Server list, you can input 10 | none
server at most
port The port of SNTP Server 123
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& Attention

Before setting SNTP Server, please ensure SNTP server could be accessed. Especially,
when SNTP server’s IP is domain name, please ensure that you have already configured

correct DNS server.

B Instruction

When setting multiple SNTP server, system will poll all the SNTP server, until find

available SNTP server.

3.1.4 Admin Access

Admin access supply user’s management. The user was divided into super user and
normal user.

Super user: there is only one super user created by system, username is adm. No
limitation in visiting switch

Normal user: created by super user, you can check switch configuration but no right to

change.

3.14.1 Create User

Click “management->admin access” in the navigation, enter “create a user”.

= PR i
A Admir >> Admin A
“lI and m ‘Modify a User [ Remove a User

Adrinistration

Create a user
Ports
Virtual LANS Username

Redundancy New Password

»
»
»
»
Security L Confirm New Password
»
»
»

QoS
Multicast Filtering [#op1y & Sav.ve‘
M:ﬁg:“ress userSummary

Username
adm

Page information description is as shown in the following table.

Name Description ‘ Default
Username New user’s username none
New password New user;s login password none
Confirm new password Confirm the new password none
22
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User summary List of current users none

3.14.2  Modify a User

Click “management->admin access” in the navigation bar, enter “modify a user”

interface.
-
& Administration >> Admin Access
fpand (S (Wt Uses] (LT
Administration >
userSummary
Ports >
virtual LANS , Uzgraama
adm
Redundancy ¥
Security L
QoS * | Modify a User
Multicast Filtering » o
Username dn
MAC Address > =
Tables New Password
Confirm New Password

Page information description is as shown in the following table.

Name Description ‘ Default
Username New user’s username none
New password New user;s login password none
Confirm new password Confirm the new password none
User summary List of current users none

3.14.3 Remove a User

Click “management->Admin access” in the navigation bar, then enter “Remove a

User”.

23
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e
L Administration >> Admin Access
Administration »
userSummary

Ports »

Virtual LANS , CECTLLD

adm

Redundancy L

QoS »

Multicast Filtering »

MAC Address ’

Tables

Page information description is as shown in the following table.

Description

User summary List current system users none

B Instruction

Attention: super user’s username “adm” could not be modified or removed.

3.1.5 Configuration management

Click “management->config management” in the navigation bar, enter ‘“config

99
management”.
&)
l:}ﬁal‘ll Administration >> Config Management !
Administration 4 . .
Configuration
Ports 4
Virtual LANs » CE.) [ Import ][ Backup ru:mx-\:onﬁa][ Backup nutw—cmﬁid
Hedundancy " | @ futo Save after modify the configuration
Security %
dod ' [ Restore default configuration ]
Multicast Filtering *
MAC Address »
Tables

Page information description is as shown in the following table.

Name Description ‘ Default
Browser Choose config files from PC none
Import Import config files to switch’s none

startup-config

Backup running-config Backup running-config to PC none
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Backup startup-config Backup startup-config to PC none
Auto save after modify the | Decide whether or not to save enable
configuration configuration automatically after

modifying configuration.

Restore default Restore Startup-config to default none

configuration configuration

‘3 Attention
When import the configuration, the system will filter incorrect configuration files,
and save the correct configuration files, when system restarts, it will orderly execute
theses configuration files. If the configuration files didn’t be arranged according to

effective order, the system won’t enter the desired state.

U’ Instruction

In order not to affect the current system running , after executing the import
configuration and restore the factory configuration, need to reboot the switch, then the
new configuration will take effect

3.1.6 SNMP

SNMP, Simple Network Management Protocol, is the most widely used network
management protocol. SNMP is used in device management, to ensure that
management information between any two points in the network transportation and
make network manager check and manage device information easily.

SNMP is divided into NMS and Agent

NMS (Network Management Station) is running client procedure work station.

Agent is a server software that running in the device.

SNMP Agent support SNMPv1, SNMPv2¢c and SNMPv3 in the current device.
SNMPv1 and SNMPv2 use community name to authenticate.

SNMPv3 use username and password to authentication encryption mode.

SNMP includes NMS and Agent:
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NMS (Network Management Station) is a station which runs client procedure.
Agent is service software which is running in device.

The purpose of NMS and Agent is as followed:

NMS can send getRequest, getNextRequest, setRequest packets to Agent, when
the Agent receive these packets, it will execute read or write operations according
to the type of packet and create Response packet back to NMS.

When device happens to status change (for example port plug), Agent will send
Trap packet and report all the events to NMS.

SNMP agent of device supports SNMPv1, SNMPv2 and SNMPv3 at present.

® SNMPvl and SNMPv2 adopt community name to authenticate.
® SNMPv3 adopt username and password to authenticate.

3.1.6.1 Configure SNMP

Click “manage->SNMP” in the navigation bar, then enter “SNMP” interface.

(o) Administration >> SNMP
fprand (SN (T

Administration »
Enable )

Ports » .

Virtual LANs > SHME:Nersion [r2e[a]
Contact Information Beijing_Inhand_Networ

Redundancy »
Location Information Beijing_China

Security »

QoS 2

Multicast Filtering » | Community Management

T R — o o

private Read-Write defaultView
Read-Only [=] [defaultview -
|
Page information description is as shown in the following table.
Name Description ‘ Default
Enable Enable or disable SNMP off
SNMP Version Choose switch SNMP version, v2c
support SNMP v1/v2/v3

Contact Information

Input contact information

Beijing Inhand Network

Location Information

Input location information

Beijing China

Name

Description

Default
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Group name Enable or disable SNMP Public and private
Access authority Choose access authority o
MIB view Choose MIB view Default view

After choosing SNMPv3, you need to configure users and user group:

QoS

Multicast Filtering User Group Management(v3)

o
(3 Administration >> SNMP
e e
Administration »
Ports , | Enable
SNMP Version
Virtual LANs 4 u
Contact Information Beijing_Inhand_Networ
Redundancy »
Location Information Beijing_China
Security »
»
»
»

MAC Address

.
Usm Management(v3)
- g 4
Page information description is as shown in the following table.
Name Description Default
Group name Input group name, length:1-32 | none
character
Security level Choose security level No Auth/No private
Read-only view Choose SNMP read-only view. Only | Default view
support default view now.
Read-write view Choose SNMP write-only view. Only | Default view
support default view now.
Inform view Choose SNMP Inform view. Only | Default view
support default view now.

Description

Default

username Input username, length:1-32 character

none
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authentication Choose authentication mode. Support | none

MD5 and SHA authentication mode.

Authentication password Input password none

Encryption Whether or not to wuse DES | DES

encryption mode

Encryption password Input password when the mode of | none
encryption is not “no encryption”.

Length: 8-32 character

Group name Add user to their group. none

3.1.6.2 Configure SNMP Trap

Click “management->SNMP” in the navigation bar, then enter “SNMP Trap”

interface.

(o] Administration >> SNMP
' (177 (SnmpTrap

Administration

Configure Snmp Trap
Ports

b

»
Virtual LANS ¥ Host address Security Name UDP Port

162

Redundancy »
Security >
QoS » .
Multicast Filtering » | AL :""":,

»

MAC Address
Tables

Page information description is as shown in the following table.

Name Description Default
Host IP address Input NMS IP address none
Security Name For v1 or v2, input group name; For | none

v3, input username. Length:1-32

characters.

UDP Port Input UDP port 162

3.1.7 Alarm

Alarm feature provides a way to inform switch exception immediately, allowing users
28
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to find out and solve these exceptions as soon as possible. When an exception occurs,
switch will issue a warning, then user can select exceptions system-defined and
choose the appropriate notice way to inform what happened. All alarms will be

recorded in the alert log for users.

According to the type of alarm, it can be divided system alarm and port alarm.

® System Alarm: It produces because of system or environment happened to some
exception, divided into temperature, hot start, cold start, power failure, power
recovery, insufficient memory.

® Port Alarm: It produces because of the network interface is up or down, divided
into LINK-UP, LINK-DOWN.

29 6

Alarm status divided into “raise”, “confirm”, “all”.The state of "raise" that means the
alarms hadn’t been confirmed, if user cann’t resolve these alarms temporarily, he can
set them to “confirm”state. The state of “all” means all the alarms

Alarm level can be divided:

EMERG: Device occurs some faults, it could lead to the system restart.
CRIT: Device occurs some faults which are unrecoverable.

WARN: Device occurs some faults which could affect system function.

NOTICE: Device occurs some faults which could affect system properties.

INFO: Device occurs some normal events.

On the “Alarm Status” page, you can view all the alarms since system was power on.
On the “Alarm Input” page, you can define alarm types which you concern.

On the “Alarm Output” page, you can set the way of alarm notice, including relay and
Email, log record is a default output way.

On the “Alarm Map” page, you can map the alarm type which you concern to one or

more alarm notice way.

3.1.7.1 Alarm Status

Click on Administrator — Alarm— Alarm Status, as the following shown:

29
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Alarm State: Al11 v
ID Status Type Level date System Time Content
82 raise systen THFO e L 1 warn-stert
Clear All Alarms ][ Confirm All Alarms ][ Reload
Page information description is as shown in the following table.
Name Description Default
ID Generated by system none
Status Current alarm status none
Type Current alarm type none
Level Current alarm level none
date The time of generated alarm none
System Time The time from startup to alarm none
Content Description of alarm none

3.1.7.2  Alarm Input

Click “Administrator — Alarm— Alarm Input” in the navigation bar, then enter “Alarm

Input”.
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(x Administration >> Alarm
' [ Al States [Tl || Alerm Output | A3 Map]
Administration >
System Alarm
Ports »
Virtual LANS » | Temperature:
Hedundancy 5 Upper Limit: g
Lower Limit: | ]
SLLE " warm stan:
gos Y| cold sta:
Multicast Filtering » Power Down:
MAC Address » | Powerlp:
Tables Memory Low
Link Alarm
Port Link-UP Link-DOWN
FE1/1
FE1/2
FE1/3
FE1/4
FE1/5
FEI/6
FE/T a
FEI/8 a
FE1/9
ioply & s;ue\

Page information description is as shown in the following table.

Name Description Default
Temperature On/Off Temperature exceeding alarm | Off.
Upper Limit Temperature upper limit none
Lower Limit Temperature lower limit none
Warm Start On/Off warm start alarm on
Cold Start On/Off cold start alarm on
Power Down On/Off power down alarm on
Power Up On/Off power up alarm on
Memory Low On/Off memory low alarm on
Link-up On/Off link-up alarm off
Link-down On/Off link-down alarm on

3.1.7.3 Alarm QOutput

bb

Click “Administration->Alarm” in the navigation bar, then enter “alarm output
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)
O Administration >> Alarm
Hpand A Sttus A O] (77

Administration

»
Relay Alarm
Ports »
Virtual LANs » Enable Relay Alarm: =]
Redund: 3
Soneney Email Alarm
Security *
QoS , | Enable Email Alarm:
Mail Server IP/Name: ]
Multicast Filtering  * )
Mail Server Port: 25 ]
¥:|,(|:e‘:ddm“ ' Account Name: ‘
\

Account Password:
Crpyt: [0 Z‘

[(2pply & Save|[uuGancal ][ Send Test Email

Page information description is as shown in the following table.

Name Description Default
Enable Relay Alarm Enable/disable relay alarm disable
Enable Email Alarm Enable/disable Email alarm disable
Mail Server IP/Name Set mail server IP address none
Mail Server Port Set mail server port 25
Account Name Set email address which system sent | none

alarm Email

Account Password Set email password which system | none

sent alarm Email

encryption Set encryption mode none

& Attention: After setting Email parameter, you should click “sent test mail” to

sent test Email, to ensure that configuration is correct.

3.1.74  Alarm Map

Click “Administration->alarm” in the navigation bar, then enter “alarm map”

interface.
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QS Administration >> Alarm

TEN T TN T

Administration
Ports
Yirtual LANSs

cmail

=
o
»
<

Output Type
Temperature
Warm Start
Cold Start
Power Down
Power Up

Multicast Filtering Memory Law

Link Uy
MAC Address FE P
Tables Link Down

Link Up
Link Down
Link Up
Link Down
Link Up
Link Down
Link Up
Link Down
Link Up
Link Dawn
Link Up
Link Down
Link Up
Link Down
Link Up
Link Down

Security System Alarm

»
»

»

Redundancy »
»

QoS »
»

»

FE1/2

FEI/3

FE1/4

Port Alarm FE1/5

FEI/B

FEI/T

FE1/8

i i O s s
i e ) e

FE1/9

kpply & Save| Cancel

3.1.8 System Log

Through “System log” interface, you can see important log since the start of switch. It
easy to understand system status and will help solve problem in time.

Through “System log” interface, you can set up remote log server, switch will take all
system log files to upload remote server, which requires remote log software (such
Kiwi Syslog Daemon).

3.1.8.1 Log

Click “Administration->System log” in the navigation bar, then enter “system log”

interface.
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o=
Ao, Administration >> Log
tpnand [ [Ssen oo
Administration »
Ports , | View recent [20 [+] Lines
Minual LAN= 2 Level Time Module Content
Redundancy » Too many logs, old logs are not displayed, Please download log file to check more logs!
Security - warning Jan 7 01:16:38 in_if{944] ignore msg(0k533c) from 115
warning Jan 701:16:38  rmond([948] ignore msg(0x5337) from 103
QoS L err Jan 701:16:38  syswatcher[836] cannot found startup config file(/etc/inswitch.conf)
Multicast Filtering > warning Jan 701:16:40  syswatcher[836] send SYSINFO to service 302t

warning Jan 7 01:17:04  Web[952] IH_PRIV_USER

1'43582‘“"99 > | waming Jan 7011718 syswatcher[838] send SYSINFO to service 301
warning Jan 7 01:34:40  syswatcher[836] send SYSINFO to service 301!
warning Jan 701:34:41  in.if(944] ignore msg(0x633b) from 306
warning Jan 7 01:34:41 in_if{9441 ignore msg(0x533b) from 306
warning Jan 7 01:34:41  in.if(944] ignore meg(0x533b) from 306
warning Jan 7 01:34:41 in_if(944] ignore msg(0x533b) from 306
warning Jan 7 01:34:41 in_if{944] ignore msq(0x533b) from 306
warning Jan 7 01:34:41  in_if(944] ignore msg(0x533b) from 306
warning Jan 7 01:34:41 in_if[944] ignore msg(0x533b) from 306
warning Jan 7 01:34:41 in_if(344] ignore msg(0x533b) from 306
warning Jan 7 01:34:41 in-if[944] ignore meg(0x533b) from 306
warning Jan 7 01:34:41  in_if[344] ignore msg(0x533c) from 306
warning Jan 701:38:41  opc.agent[946]  ignore msg(0x5337) from 103
warning Jan 7 01:35:11 syswatcher[836] send SYSINFO to service 301!

[ clear Log | Download Log File |

Manual et restz] [ Rofresh |

3.1.8.2  System Log

Click “Administration->system log” in the navigation bar, then enter “system log”

interface.
l:ﬁa:u Administration >> Log
(Log
Administration »
Ports , | Log to Remote System =
EET % IP Address / Port(UDP) 514
Redundancy L
QoS L
Multicast Filtering
MAC Address 3
Tables

Page information description is as shown in the following table.

Name Description Default
Log to remote system On/Off remote log function disabled
IP Address/Port(UDP) Set remote server IP/port none

3.1.8.3  Kiwi Syslog Daemon

Kiwi Syslog Daemon is a free log server software which is used for Windows. It
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can receive, record, display the log information of host(such as router, switch, Unix
host). After download and install Kiwi Syslog Daemon, configure necessary

parameters on the configuration page of File->Setup->Input->UDP.

3.1.9 System Upgrade

Click “Administration->system upgrade” in the navigation bar, then enter “system

upgrade” interface.

-

Adrninistration

Select the file to use:

Ports Upgrade

Virtual LANs
Current Version : 1,0,0,r2601
Redundancy

»

»

»

»
Security »
QoS »
Multicast Filtering »
»

MAC Address
Tables

Click on “browser” button and select upgrade file, then click “upgrade” start to upgrade. The

process will be lasted around 1 minute, after finishing, reboot switch.

3.1.10 Reboot

Click “Administration->reboot” in the navigation bar, then enter “reboot” interface.

(o -] corie
P 4 Administration >> Reboot

Administration ;vs‘em -
Networks
System Time
Admin Access
Config Management
SNMP

Alarm

Ports
Virtual LANs

1.0.0.r2601

< i

QoS

Filtering

MAC Address
Tables Upgrade

Reboot
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3.2 Ports

3.2.1 Ports

Port configuration incudes port status, port basic parameters, port advanced

parameters, port mirror.

3.2.1.1 Port Status

Click “Ports->Ports” in the navigation bar, then enter “Port Status” interface.

)
QS Ports >> Ports )
ﬁ Port Advanced Parameters |[ Configure Port Mirroring

Administration > ~
Port Link Status Current Speed Current Duplex

Forts | FEn unkue 100M FULL

Virtual LANs 4 FEI/2  LINK DOWN = -—
FEI/3  LINK DOWN ot =

Redundancy | ree unkoown = =

Security ¥ FEI/S  LINK DOWN = S

QoS , | FEE  UNKDOWN — -

FEI/T  LINK DOWN g e
Multicast Filtering » FE1/8  LINK DOWN == S

MAC Address > FEI/3  LINK DOWN = -
Tables

Manual Refresh:

This page displays port status, includes port number, link status, current speed,

current duplex.

3.2.1.2  Configure Port Basic Parameters

Click “Ports->Ports” in the navigation bar, then enter “Port Basic Parameters”.

( o
P Ports >> Ports
I _ Port Advanced Parameters [ Configure Port Mirroring |

Administration »
Ports ) Port g’;‘}g Speed Duplex Flow Control Protected Description
virtual LANs » | FEL e [v]laute [v] [aute  [v] [Disable[r] [normal [+]
Redundancy > FEl/2 lwp : auto : Disable : normal :
SoeuTty , | FEW3 [up [+] auto [+] [auto [+] Disable[+] normal [+]
e | e :El :E] asto[7] [Disable[] [normal [7]
FEI/S fwp  [¢]auto [¥] [aute [] [Disable[r] normal [¥]
e > |20 5L ] e o e et
{3

e s T e [5]e [5] [swte [] (bisablels] [nermal ]
FE1/8 ‘up v| [auto =] [auto ~| [Disable[+| normal [+

FE1/9 |up v]|aute  [+] [aute  [+] Disable[v] normal [+]

Page information description is as shown in the following table.

Name Description Default
Admin Status Up(enable), Down(disable) up
Speed 10M,100M,1000M or Auto auto
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Duplex Half, full or auto auto

Flow Control Enable, disable disable

Protected Normal, isolated normal

Description The description of ports none
3.2.1.3 Port Advanced Parameters

Click “Ports->Ports” in the navigation bar, then enter “Port Advanced Parameters”

interface.
)
> Ports >> Ports
fpand (T (R o Avnean Parmetos] (2 T
Administration »
Ports , | Pot  Leam Learn Limit Storm Control Storm Rate(kbps)  Ingress Rate(kbps)  Exceed Action Egress Rate(kbps) ,B,g’:k';t”“""‘"
Virtual LANs » | FEI/1 [Enable[+] D [none = | 0 none
RodUadancy | FEI2 [Enable[+] 0 [none = o none
Security " FEI/3 |Enable 0 [none = [ o none
e , | FEV4 [Endble[+] 0 [none = 0 none
0. =
FEI/S [Enable[+] 0 |none = 0 [none
o . s J
pitcastiienns FEI/6 |Enable[~]| 0 |none = 1] none
MAC Address Y| el [Enable[s] 0 [none =2 1o none
FEI/8 |Enable] [none = [ [] [none
FE1/3 |Enable[v| 0 [none = [ 0 none
NOTE:
Flow control of exceed action will not be activated until enable the flow control feature on the 'Port Basic Parameters' page,
Epply & Save|[uCancel )

Page information description is as shown in the following table.

Name Description Default
Enable monitor Enable or Disable Disable
Destination port Mapping destination port none
Source port parameter Appointed mapping port and | none

mapping direction, mapping direction
could choose: none, ingress, egress,

both

Leaning Status Enable, Disable Enable
The MAX Number The max number of dynamicaly learning MAC address. none
Range <1-255>
Broadcast Control That means which types broadcast will be limited. The none
type is as followed:
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none
unicast
multicast
broadcast
unicast& multicast
unicast& broadcast
multicast& broadcast
all
Broadcast rate(kbps) Desigate broadcast flow rate limit, range is 64-1000000 = none
Infow rate(kbps) Infow rate limit, range<64-1000000> none
Excessive treament When inflow rate over the limit, the treatment can be: drop
Drop,
Flow-control,
Outflow rate (kbps) Outflow limit, range<64-1000000> none
Block unknown packets Blocking unknown packets. The flowing type can be
choosed:
none,
unicast,
multicast,
both(unicast or multicast)
Drop packet type Drop the received packets, the flowing packet type can = none
be choosed
none,
tagged,
untagged
VLAN transparent In normal case, if the vlan id which port belongs to is = Disable
transmission not same with the vlan id of received packets carry. The
packet will be droped, but if enable the vlan transparent
trasnmissoin, the packet won’t be droped.

3.2.1.4  Configure Port Mirrioring

Click “Ports->Ports” in the navigation bar, then enter “configure port mirroring”

interface.
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L Ports >> Ports
T e ]

Administration

Enable monitor

Destination Port none [~

Source Port Parameter

Ports
Virtual LANs

Redundancy

gt Dlg?:t;un

Multicast Filtering FEV ‘EB
MAC Address =l
Tables FE1/3
FEI/4 [nene [~]
FE1/S
Feve
e
eI
revs

I3

I3

»

»

Security LS
QoS »
»

»

The flow of ingress from source port FE1/2 and the flow of egress from source

port FE1/3 was mapped to destination port FE1/1.

Page information description is as shown in the following table.

Name Description Default
Enable monitor Enable or Disable Disable
Destination port Mapping destination port none
Source port parameter Appointed mapping port and | none

mapping direction, mapping direction
could choose: none, ingress, egress,

both

3.2.2 Ethernet Statistics

3.2.2.1 Port Statistics

Click “Ports->Ethernet Statistics” in the navigation bar, then enter “Port Statistics”

interface.
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Nl
Q Ports >> Ethernet Statistics N
fphand CloarSitistics | AMON Statisics | AMON History [ RMON Al | RWON Evnts
Administration L
Pont InOctets 0 InDiscard InUni OutUni InMulti 0 InBroad; OutBroad,
Forts, * | FEl/1 00000000000000878509 00000O00000012006650 000000000 D00UOO7355  (O0DI23%6  OOODDODIG3 000000730 00000041 0000000000
Virtual LANs » | FE1/2 00000000000000000000 00000O0000000000000D 0000000000 000000000 000000000 0000000000 000000000~ 0000000000 0000000000
T , | FE1/3 0000000000000000000D  D0OODODO0OOOO0D00D  0DDODNO0D  OOD0OODDD ~ 0ODDOOOD~ DODUOOOOD~~00O00C0DO0~~ DDV000000 0000000000
FE1/4 00000000000000000000 00000000000000000000 0000000000 0000000000 0000000000 0000000000 0000000000 0000000000 0000000000
Security » | FE1/5 00000000000000000000 000000000000C0000000 0000000000 0000000000 0000000000 000000000~~~ 0000000000~ 0000000000 0000000000
Qo8 , | FE1/6 00000000000000000000 0000000000000000000D 0000000000 000000000 000000000 00DOO0OO0D 0000000000~ 0000000000 0000000000
FE1/7 00000000000000000000 00000000000000000000 0000000000 0000000000 0000000000 000000000 0000000000 0000000000 0000000000
Multicast Filtering > | Fe1/5 0D000000000000000000  000000000000C0000000 0000000000 0000000000~ 0000000000~ 0000000000~~~ 0000000000 0000000000 0000000000
MAC Address » | FE1/3 00000000000000000000 00000000000000000000 0000000000 0000000000 000D0J0000 0000000000~~~ 0000000000~~~ 0000000000 0000000000
Tables

3.2.2.2 Clear Statistics

Click “Ports->Ethernet Statistics” in the navigation bar, then enter “Clear Statistics”
interface.

In the table, it chooses port FE1/1 and FE1/2. The port information of statistics will be

clear after applying.
o]
(3 Ports >> Ethemet Statistics ‘
Administration 4
, . FEI/1 FEI/2 FE/3 FEI/4 FEI/5 FEI/E FEIT FEI/B FEI/9
orts
Virtual LANs 4
.
Security L o
| oS ,
Multicast Filtering »
MAC Address 4
Tables

3.2.2.3 RMON Statistics

Click “Ports->Ethernet Statistics” in the navigation bar, then enter “RMON Statistics”

interface.
-
O Ports >> Ethemet Statistics
Administration »
Port N Index Port Owner
ons FEU1 [] Menitor
Virtual LANs L
Redundancy L
Security iz
QoS 4 -
Multicast Filtering  »
MAC Address »
Tables

Page information description is as shown in the following table.

Name Description Default
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Index Input index number, range from | none
1-65534

Port Input port number FE1/1

Owner Input owner’s name Monitor

3.2.24 RMON History

Click “Ports->Ethernet Statistics” in the navigation bar, then enter “RMON History”

interface.
)

L Ports >> Ethernet Statistics :

B s [ Clonr St [ Ao taistics | [ iMON Nlarms | RMON Evots |
Administration

Requested Granted

Ports Index Port ﬂ?.lcksts Buckete Interval Owner
Virtual LANs FEL/L [+ L HMonitor
Redundancy

QoS
Multicast Filtering

MAC Address
Tables

(i o i)

»
»
»
»
Security »
»
»
»

Page information description is as shown in the following table.

Name Description Default
Index Input index number, range from | None
1-65535
Port Choose port FE1/1
Requested Buckets Management station expected | None

sampling gross

Granted Buckets Device saved sampling gross None
Interval Sampling time(second) None
Owner Owner’s name Monitor

3.2.2.5 RMON Alarms

When the alarm is triggered, if you need to manage device(NMS) to send Trap

messages, please ensure that SNMP function has been configured correctly before
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configuration of RMON alarm feature.
Statistics Section alarm variable is defined in the MIB variable, it must configure
RMON Ethernet statistics under monitored Ethernet interface.

Click “Ports->Ethernet Statistics” in the navigation bar, then enter “RMON Alarm”

interface.
(4. Ports >> Ethemnet Statistics
fpane [Fort st | Clea e | AMON Staisics [ AMON Histoy || || AMON Eveni |
Administration 4
o ; Mlarm Object  S'YUSNCS  piging The  Falling The  Value  Type  Interval Siartu Rising Event
Virtual LANSs > [DropEvents [+ ~] [ J[de1td=] rising0r[~]
Redundancy >
Security 3
Multicast Filtering »
MAC Address >
Tables
Page information description is as shown in the following table.
Name Description Default
Index Input index number, range from | None
1-65535
Alarm Object Choose the monitored RMON-MIB | DropEvents
object
Statistics Index Choose statistics index None
Rising Thr Input sampling statistics rising thr None
Falling Thr Input sampling statistics falling thr None
Value Monitor variable value None
Type Absolute or Delta delta
Interval Sampling time interval None
Startup Alarm Only support rising or falling Rising or falling
Rising Event When it exceeds rising limit, trigger | None
rising event index
Falling Event When it exceeds falling limit, trigger | None
falling event index
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Owner Owner’s name Monitor

3.2.2.6 RMON Events

Click “Ports->Ethernet Statistics” in the navigation bar, then enter “RMON Events”
interface.

.(“ Ports >> Ethemet Statistics

e ot tatstcs ] Cloa S JiON Sttsics [ WO isary [N warms [ 1|
Administration 4

T Index Type Community Last Time Sent Description Owner
Fons |none : Monitor
Virtual LANSs >
Redundancy 3
Security >
QoS >
Multicast Filtering »
MAC Address »
Tables
Page information description is as shown in the following table.
Name Description Default
Index Input index number, range from | None
1-65535

Type Choose the type of triggered events: | None

log, trap, log-trap, none

Community Trap’s group name(only for type | None

log-trap and trap)

Last Time Sent Record latest triggered event, | None

generated by system

Description Description of event None

Owner Owner’s name Moniter

3.2.3 Link Aggregation

Link aggregation provides a mechanism to aggregate multiple physical ports into one
logical link.

The advantage of link aggregation: linear increase bandwidth; link redundancy..

3.2.3.1 Configure Port Trunk

Click “Ports->Link aggregation” in the navigation bar, then enter “Configure Port
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Trunks” interface.

Put FE1/1, FE1/2, FE1/3, FE1/4 into aggregation group Trunk 1.

.(0‘ Ports >> Link Aggregation
I [[Configure Port Trunks|

Administration >
Foria , | Trunk Policy [sada[
Viftatll ANa r TunklD  FEIA FEI2 FEI/3 FEI/4 FEI/S FEI6 FEI/T FEI/B FEI/8
Redundancy > 1 [} B B B
Sacuriy 5 2 & B B &
ot : 3 & B B B B B

4 & B B B
Multicast Filtering » 5 & B @] il B B B
MAC Address > & (] B B (] B B B
Tables

Page information description is as shown in the following table.
Name Description Default
Policy Load balancing strategy, you could | sada
choose: sada or hash.

Trunk port Appointed trunk member None

3.3 Virtual LANs

VLAN can be flexible on the physical network into logical. It cannot communicate
directly between different VLAN, which to some extent, to ensure data and
information security. In addition, VLAN isolated broadcast domain, making the
network efficiency can be improved. VLAN also provides simple and flexible
management, the physical network could be divided into segments separated from

each other.
® VLAN Frame Type
Tagged Frame: Carrying the VLAN tag . TPID is 0x8100, the VID of TCI is 0;

Priority Tagged Frame: TPID is 0x8100, the VID of TCI is 0.

Untagged Frame: The frame except Tagged frame and priority tagged.
® VLAN Member Type
Tagged Member, When the VLAN frame is sent from a member port, will bring the VLAN

label, that is sending the Tagged frame.
Untagged Member, When the VLAN frame is sent form a member port, won’t bring the

VLAN label, that is sending the untagged frame.
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® PVID
The default VLAN which port belong to.

3.3.1 VLAN Summary

Click “Virtual LANs->Static Virtual LANs” in the navigation bar, then enter “VLAN

Summary” interface.

-
L Virtual LANs >> Static Virtual LANs
I ﬁ Configure VLAN Parameters
Adrministration »
VLAN ID Name Priority Untagged Ports Tagged Ports
Ports > 1(Default)  WLANDODI 0 FE1/1.FE1/2 FE1/3,FE1/4 FE1/5,FE1/6,FE1/TFE1/B.FE1/S
Virtual LANs 4
Redundancy * Manual Rz.-frash:
Security 2
QoS >
Multicast Filtering »
MAC Address L
Tables

3.3.2 Configure VLAN Parameters

Click “Virtual LANs->Static Virtual LANs” in the navigation bar, then enter
“Configure VLAN Parameters” interface.
For example, VLAN ID is 2, name is test, FE1/1 and FE1/2 is untagged member,

FE1/3 is tagged member.

)
Q virtual LANs >> Static Virtual LANS
pnd T | oo v P

Administration 4

VLAN ID Priority Name FE1/1 FE1/2 FE1/3 FE1/4 FE1/5 FE1/6 FE1/7
bons ' 1 0 VLANOOD! uttagged  untagged  untagged  untagged  untagged  untaaged  untagge
Virtual LANs ' o |none ¥] [rone  [+] [none | [none v [none v] [none  [¥] [none
Redundancy >
Security »
Multicast Filtering » : '
MAC Address 4
Tables

Page information description is as shown in the following table.

Name Description Default
VLANID VLAN ID, range from 1-4094 1
Priority VLAN Priority, range from 0-7 0
Name VLAN name VLANO001
Port member Choose port member role, you could | none
choose: none, tagged, untagged.
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3.4 Redundancy

Redundancy, which is a part of the network circuit that has some malfunctions will
have a backup path. This is the most basic requirements of industrial automation
applications. IEEE 802.1D Rapid Spanning Tree Protocol and ITU-T G8032 ring

protection technology are the latest technology.

3.4.1 RSTP

The main role of the RSTP includes two aspects: first, by blocking the link to
eliminate redundant network paths that may exist in loop; second, the current active
path fails, the link activate redundant backup and restore network connectivity,
enabling backup links.

RSTP, by sending a special packet protocol between switch each other, process

received packet according to spanning tree algorithm, then determine the network
topology.
34.1.1 Bridge RSTP Statistics

Click “Redundancy-> RSTP” in the navigation bar, then enter “Bridge RSTP

T
Statistics”.
)
Lo Redundancy >> RSTP
1 W Port RSTP Statistics || Configure ASTP Parameters
Administration ’
Bridge Status: Root Bridge
Ports "| eridee i 32768/0018, 05a0,0024
Virtual LANs » Root ID: 32768/00186, 05a0.002d
Root Port: =
»
fedundency FRioot Port Priority: -
Security * | Root Path Cost: 0
QoS y | Configured Hello Time: 2
. iy Learned Hello Time: 0
Multicast Filtering  » Configured Forward Delay: 15
MAC Address » | Learned Forward Delay: 0
Tables Configured Max Age: 20
Learned Max Age:! 0
Total Topology Changes: 0
Time since Last TC: 0 days 0:29:57
[Maral Refreshlv]

3.4.1.2 Port RSTP Statistics

Click “Redundancy-> RSTP” in the navigation bar, then enter “Port RSTP Statistics”.
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o -] Redundancy >> RSTP
(PR ST Staaies] (00

Administration 4

Port  Protocol Status Role RXRSTs TXRSTs RX Confige TX Confige RX Tens TX Tcns
Ports ¥ FE1/1  Enabled FORWARDING  Designated 0 903 1) 1} 0 1}
Virtual LANs > FE1/2  Enabled LINK-DOWN = 0 0 a 0 0 0
Redundancy 0 FEI/3  Enabled LINK-DOWN E 0 0 0 ] 0 0

FEI/4  Enabled LINK-DOWN - 0 0 0 0 0 0
Security ¥ FEI/5  Enabled LINK-DOWN = 0 0 0 1] 0 0
QoS » FEI/6  Enabled  LINK-DOWN = 0 0 0 0 0 0

FEI/T  Enabled LINK-DOWN o= 0 0 0 i} 0 0
Multicast Filtering  » FEI/8 Enabled  LINK-DOWN - 0 0 0 0 0 0
MAC Address > FEI/9 Enabled  LINK-DOWN - 0 0 0 0 0 0
Tables

Manual Reireﬂ:

3.4.1.3  Configure RSTP Parameters

Click “Redundancy’] RSTP” in the navigation bar, then enter “Configure RSTP

LR
Parameters”.
-
N Redundancy >> RSTP
WS | ot Pt
Administration »
Ports ¥ Enable RSTP
i fori 32768
TR - Bridae Priority 32768~ ]
Hello Time 2 (1-10)s
Redundancy »
~ Max Age 20 (6-40)s
Security »
Forward Delay 15 (4-30)s
QoS L
Transmit Hold Count 6 (1-20)
Multicast Filtering *
MAC Address * | Port RSTP Parameters
ables
Port Enable RSTP Paort Priority Spanning-tree Cost Edge Port Point-to-Point
FE1/1 Enable -] [128 futo o v] [auto -
- wo O
FE1/3 Enable ~] [128 Auto To +] [Auto -
FE1/4 [Enzble (128 Auto [T [+] [auto =]
FEI/S [Enable [=] [128 [] Auto [Ho [+] [futo =]
FEI/6 [Enable =] [128 Auto No ~] [duto -
T el [ wo o [
FE1/8 [Enable [=] (128 [7] Auto [Wo [+] [duto =]
FE1/9 Enable :l 128 Auto o j Auto :

Page information description is as shown in the following table.

Name Description Default
Enable RSTP Enable or disable RSTP enable
Bridge Priority Set RSTP bridge priority, range from | 32768
0-61440
Hello Time Set RSTP timing time interval when | 2
sent BPDU packet, range from 1-10
seconds.
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Max Age Set RSTP BPDU max life time, range | 20
from 6-40 seconds

Forward Delay Set RSTP spanning tree delay, range | 15
from 4-30 seconds.

Transmit Hold Count Set transmit hold count per second 6

Name Description Default

Enable RSTP Enable or disable RSTP Disable

Port Priority Set RSTP port priority, range from | 128
0-240

Spanning-tree Cost Set RSTP port route, range from | Auto
1-200000000 or auto

Edge Port Set value of edge port, yes means | No
force configured edge port, no means
auto

Point-to-Point Set connection value of | Auto
point-to-point. Yes means force

configured point-to-point port; no
means force configured port shared

link.

& Attention

Hello time, the max age time, and forward delay, the three paremeters have their own

value range, and they need to meet the following relationship:
2*(Hello Time + 1.0 seconds) <= Max-Age Time <= 2*(Forward-Delay — 1.0seconds)

The three parameters must meet this requirement, otherwise may lead to topology is

instable.
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3.4.2 G.8032v2 ERPS

Ring protection technology is an open protocol launched by ITU which is applied in
the data link layer. It can prevent broadcast storms caused by data loops. When the
loop-line link or equipment failed, it can switch to a backup link, to ensure than quick
business recovery. Rapid Ring Protection Protocol is the use of ring fault recovery
within a dedicated control network VLAN passing ring network control message.
Also, it combined with the topological characteristics of the ring itself, if malfunction
was found out, backup link will be enabled and achieve rapid recovery.

In the protection of technology, rapid spanning tree technology has been widely used.
RSTP will occupy the port resources, however, the recovery time of RSTP is in the
second level and cannot meet the demanding real-time in the industrial applications.
More faster RSTP, ring protection protocol link malfunction recovery time can be less

than Sms.

34.2.1 Ring Instances Status

Click “Redundancy->G.8032v2 ERPS” in the navigation bar, then enter “Ring

Instance Status” interface.

info@jdktech.com.au

L = Redundancy >> G.8032v2 ERPS |_I
Administration >
S| g MR NS oeecsor SO Mol LetBhnfees Mty gics o
Virtual LANs »
Redundancy > Manual Refresh[v|
Security »
QoS >
Multicast Filtering »
MAC Address >
Tables

.
3.4.2.2  Ring Instance

Click “Redundancy->G.8032v2 ERPS” in the navigation bar, then enter “Ring
Instance” interface.
“Fast Configure Normal Node”, automatic configure ring normal node

“Fast Configure Owner Node”, automatic configure ring owner node
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! Attention

The default ring port in “Fast Configure” is based on InSwitch model.

Page information description is as shown in the following table.

Model Left Port Right Port
InSwitch 2008D FE1/7 FE1/8
InSwitch 2009D FE1/7 FE1/8
InSwitch 3010D GX1/1 GX1/2
InSwitch 3028U GEl/1 GE1/2

“Ring Instance” page is as shown in the following

-
.(0 Redundancy >> G.8032v2 ERPS
| Ring Instances Status ﬁ@

Administration 4
Fast Config
Ports »
Virual LANS » | [ Fast Config Nornal I OR [ Fast Config Owner N
Redundancy 12
Security » | Advanced Config
oS > | Instance  ping Type  Major Ring ID Node Type  Gonire! Service VLAN Left Port  Right Port
Multicast Filtering  » I—
R L & I = | I [ =L Is
ress »
Tables
NOTE:
Create major ring node instance before create sub-ring interconnective node instance.
Text format for "Service VLAN'! "vid1,vid2, ..., vidN',
FE1/9 can not be used as 'Left Port’ or ‘Right Port’ on ISM2009D switch.

Page information description is as shown in the following table.

Name Description Default
Instance ID Set ring instance, range from 1-10 None
Ring Type Set ring type, including major ring, | None

sub-ring without V-chan, sub-ring

with V-chan.
Major Ring ID Set when choose sub-ring. None
Node Type Set node type, including owner node, | None

neighbor node, normal node and

interconnection node.

Control VLAN Set control VLAN, range from | None
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1-4094
Service VLAN Set service VLAN, range from | None
1-4094
Left Port Set left port None
Right Port Set right port None

& Attention

[1] When the node was configured major ring node, it cannot be configured subordinate
major ring instance 1D, value is 0.

[2] When you configure interconnection node, you need to configure ring type sub-ring
node. Major ring node cannot be configured as interconnection node.

[3] Before configuring the data VLAN of ring instance, you need to created new VLAN.

[4] You need add ring port into configured control VLAN and data VLAN

3423 OAM

Click “Redundancy->G.8032v2 ERPS” in the navigation bar, then enter “OAM”

interface.

-
L3 Redundancy >> G.8032v2 ERPS
I [ Ring Instances Status |[Ring Instance ﬁ

Adrinistration

Port 0AM Status

FEi/1 [Disable -
FEl/2  [Disable
FEY/3  [bisable  [v]

»
Ports ’
»
I3
Security 3 FE1/4 |Disable
. L
»
»

Virtual LANs

&

Redundancy

e FE1/s (@E
Multicast Filtering FEI/6  [Disable =]
MAC Address FEV/7  [Disable  [7]
Tables FE1/8 [Disable [~

FEVS  [Dismle  [5]

Description Default

OAM Status Set OAM Status. Disable

3.4.3 iRing Ethernet Ring Network Protection

iRing Ethernet ring protection protocol is private ring protocol developed by inhand.
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IRing Ethernet ring protection protocol define node role on the loop, and use VLAN
control transmission protocol message to protect loop, make the loop quickly switch
when fauls happen, switch time less than 50ms.

iRing Ethernet ring network protection system is suitable single ring topology, can
effectively deal with single fault of a ring network, topology convergence rate quick,

and has nothing to do with the number of nodes.

3.4.3.1 iRing Status

Click “Redundancy->iRing” in the navigation bar, then enter “iRing status” interface.

Redundancy > > iRing

Now Active Enable
Node Tvpe master node
Node Status failed
Primary Port
Port Name FE 1/7
Link Status link down
Port Status blocking
Secondary Port
Port Name FE 1/8
Link Status link down
Port Status hlocking

3.4.3.1 Configure iRing

Click “Redundancy->iRing” in the navigation bar, then enter “iRing configuration”

interface.
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Redundancy > > iRing

.~ |[Config iRing

Enable iRing

Primary Port
Secondary Port

Priority (1-65535)

[ Apply & Save” Cancel ]

Enable iRing whether to enable iRing protocol

Primary Port designate the main prot FE1/7
Secondary Port designate the secondary prot FE1/8
Priority Switch differentiate the primary or 100

secondary port according to the
priority.The port which have
minimum MAC address or lowest
priority will become the primary
port

& Attention

The default primary and secondary port are different for different switch model.

The default primary and secondary port are shown as following table.

InSwitch Model Secondary Port

InSwitch 2008D FE 1/7 FE 1/8
InSwitch 2009D FE 1/7 FE 1/8
InSwitch 3010D GX1/1 GX1/2
InSwitch 3028U GE1/1 GE1/2

3.5 Security

You can use port security with dynamically learned and static MAC addresses to
restrict a port's ingress traffic by limiting the MAC addresses that are allowed to send
traffic into the port. When you assign secure MAC addresses to a secure port, the port

does not forward ingress traffic that has source addresses outside the group of defined
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addresses. If you limit the number of secure MAC addresses to one and assign a
single secure MAC address, the device attached to that port has the full bandwidth of
the port.

3.5.1 Display Port Security

Click “Security->Port Security” in the navigation bar, then enter “Port Security”

interface.
-
'(\ Secu’lty )> Port Secu"ly _
Administration 4 . " o —
lax Secure umber
Ports 4 Port Security MAC Secure MAC
Virual LANs wil [EEl et ’ g
FEl/2  off 0 0
Redundancy L4 FE1/3  off 0 0
Security v | FEI4 off 0 0
FEI/S  off 0 0
Qus o GE 0 0
Multicast Filtering » FEV/7 off L} 0
FEW/8  off 0 0
MAC Add >
Tables ress FE1/9  off 0 0
NOTE:Click the row to configure security feature on the port,

3.5.2 Port Security

Click “Security->Port Security” in the navigation bar, then enter “Port Security”

interface.
N
‘(\ o _
Administration 3 —
Max Secure  Number of
Ports K Port Security MAC Secure MAC
Virtual LANs pil ket st g g
FEI/2  off 0 0
Redundancy Y| OFE3 off 0 0
Security > FE1/4  off 0 0
FEI/S  off 0 0
QoS o 0 0
Multicast Filtering » FE/T  off 0 0
FEW/B  off 0 0
MAC Add >
Tables ress FE1/9  off 0 0
NOTE:Click the row to configure security feature on the port,

You can click each port line to configure port security characteristic.

o]
.(‘ Securﬂy >> Port secuﬁty ;

Administration »
FE1/1
Ports »
Virtual LANs » Enable Port Security
Redundancy » Max Secure MAC 1
Security 5 VLAN ID Secure MAC
Q08 1 ~| oooo.oooo.oo01
i} »
Multicast Filtering »
MAC Address ' | NOTE:
Tables Text style of MAC address: HHHH.HHHH HHHH, For example, 0000,0000,0001,
[(%ply & Save|[ Camcel | Back |
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Name Description Default
Enable Port Security Enable or disable Disable
Max Secure MAC Max number can be set 1
VLAN ID VLAN ID of MAC address 1
Secure MAC Configured secure MAC address, form | 0000.0000.0001
should be HHHH.HHHH . HHHH
3.6 QoS

QoS (Quality of Service) that is the quality of service, can guarantee the reception of
high priority data frame and accelerate high-priority data frame transmission, to
ensure that critical business will not be impact by network congestion. InSwitch
support four service levels, according t data frame reception port, Tag priority and IP

priority level to determine service level.

3.6.1 Priority to Queue Mapping

Click “QoS->QoS” in the navigation bar, then enter “Priority to Queue Mapping”

interface.

QS

int
Administration
Ports

Virtual LANs
Redundancy
Security

QoS

Multicast Filtering

MAC Address
Tables

QoS >> QoS

Priority Queue

N -
O
e L [
3 1 [~]
¢ B[
5
3
7

2 -
3 :
(R

Apply & Save

[ Cancer Default All

Priority IEEE Tag Priority None
Service level, range<0-3>, The number Default Mapping:
is more greater, the sevice level is more = Priority Level 0-1  --->Queue0
Quene higher Priority Level 2-3  --->Queuel
Note: The range of rack switch<0-7> Priority Level 4-5 --->Queue2
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Priority Level 6-7 --->Queue3
Note: The default map of rack
switch:

Priority Level 0 --->Queue 0
Priority Level 1  --->Queue 1
Priority Level 2 --->Queue 2
Priority Level 3 --->Queue 3
Priority Level 4 --->Queue 4
Priority Level 5 --->Queue 5
Priority Level 6  --->Queue 6
Priority Level 7 --->Queue 7

3.6.2 DSCP to Queue Mapping

Click “QoS->QoS” in the navigation bar, then enter “DSCP to Queue Mapping”

interface.

( NG
P QoS >> QoS
fpand (117 s Wi |

Administration

>

DSCP Queue
Ports

Virtual LANs

Redundancy

v
»
>
»

Security ¥
»
] 3
»

QoS
Multicast Filtering

MAC Address
Tables

L

J

T

]
B
[1]

il

Name Description Default

DSCP IP priority, range from<0-63> None

Queue Service level, range from<0-3>. Default mapping:

Priority 0-15=> Queue 0
Priority 16-31 = Queue 1
Priority 32-47 - Queue 2

Priority 48-63 = Queue 3
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3.6.3 Port QoS

Click “QoS->QoS” in the navigation bar, then enter “Port QoS interface.

S
A T e l!
Seinisisten ’ i Priority Override Priority Remap :
Ports | DA SA VD Pi0 Pl Pi2 Pi3 P4 Prs Prs  paz O
VIIEEANS I A o £ | T a2 = £ | 2 o 2 2 e 2 O
Redwdiney | P2 [ Gllownidal - Gl G- ECECEHCEHCECECECEC @
Security > FEV3 [wer  [o] [oversids] - = ZE = ~ U] |- Ll [ | ;E EE EE o =]
a0 o| P [lleenids] - [ FFE-EFEFE-E-ECECEL
Moticast Fitering » | FEVE e Ellowmidsl - - F-E-EFEFECE-ECE-EL E
PP ) i o | o o i [ £ | o | o SN 6 [ 5 S 6 S S |
Tables 3 N | T O N £ )l o Gl o = o 2 f I
FEVE [wrr  [o] [overridy] - [ EFEFEFEEECECECECEE &
FEVS [wer  [o]foverside] - [l [MEEFEEEFECEERIEEERPRECF
Name Description Default
Policy Port sending queue policy, you could | Wrr
choose: Queue 3:2:1:0 should
Wrr(Weighted rotation strategy) match weight 8:4:2:1
Sp(Strict priority policy)
Priority Override Change data frame tag priority | Disable
according to information below:
Destination MAC, source MAC,
VLAN ID
Priority Remap Data frame original tag priority was | No change
mapped new tag priority.
Priority Port default priority, range from 0-7 0

3.7 Multicast Filtering

InSwitch multicast filtering features:

® [GMP Snooping support industrial standard IGMP v1,v2,v3 (RFC 1112, RFC
2236, RFC 3376), has active and passive mode.

® Support enabling or disabling IGMP Snooping base on VLAN,up to 16 VLAN
can enable IGMP Snooping.

® Support multi-router port’s static configuration and IGMP Snooping dynamic
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identification.

Support IGMP Snooping operation in “no-router’” surrounding
Support IGMP multicast group member port’s static configuration
Support static multicast group configuration

Support 256 multicast group

3.7.1 1P Multicast Group

Click “Multicast Filtering-> Multicast Filtering” in the navigation bar, then enter “IP
Multicast Group” interface.
In the table, you will see IP multicast group information, including VLAN ID, IP

address, Joined ports, Router ports, MAC address.

o]
Q Multicast Filtering >> Multicast Filtering
I Multicast Group Summary ‘Configure Static Multicast Groups |
Administration
Port VLAN ID IP Address Joined Ports Router Ports MAC Address
orts
Virtual LANs

»
»

’ [ ———————
Redundancy , Fanual Refresh=]
Security »
QoS »
Multicast Filtering *
»

MAC Address
Tables

3.7.2 Multicast Group Summary

Click “Multicast Filtering-> Multicast Filtering” in the navigation bar, then enter “IP
Multicast Group” interface.

In the table, you will see multicast group summary of dynamic configuration,
including VLAN ID, MAC address, static port.

o]
.(4 Multicast Filtering > > Multicast Filtering
I IP Multicast Group ﬁ (IGMP Parameters Configure Static Multicast Groups |

Administration

VLAN ID MAC Address Static Ports GMRP Dynamic Ports

[Manual Refreshv]

Ports

Virtual LANs
Redundancy
Security

QoS

Multicast Filtering

MAC Address
Tables

3.7.3 IGMP Parameters

Click “Multicast Filtering-> Multicast Filtering” in the navigation bar, then enter “IP
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Multicast Group” interface.

-(‘. Multicast Filtering >> Multicast Filtering B
Administration »
P Enable IGMP Snooping @
orts 4 :

Virtual LANs » Mode ﬂ

i ~ Query Interval 60 s (10-3600)

s i , Router Forwarding

S RSTP Flooding ott[7]

QoS L

Multicast Filtering » | Router Ports

¥:.ﬁ;:‘“'955 t FEI/1 FEI/2 FEI/3 FEI/4 FEI/5 FEI/B FEI/T FEI/B FEI/3

Config VLAN IGMP-snooping
VD |GMP Snooping
1 [Disable [+
Multicast Group Static Member
MAC Address VLAN ID FEI/I FEI/2 FE1/3 FEI/4 FEI/5 FEI/6 FEI/7 FEI/8 FE1/9
0100. 5E00. 0000 1 - B
Name Description Default
MAC address Input MAC address that match with | None
IGMP multicast group
VLANID Choose multicast group VLAN None
Port Choose IGMP multicast group’s static | None
member port

3.7.4 Configure Static Multicast Groups

Click “Multicast Filtering-> Multicast Filtering” in the navigation bar, then enter “IP
Multicast Group” interface.
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o]

(S Multicast Filtering > > Multicast Filtering
I 11? Multicast Group ] Multicast Group Summary |/ IGMP Parameters
Administration
= MAC Address VLAN ID Priority FEI/l  FEl/2  FE/3  FEl/4  FEI/5  FEI6 FI
o 0100. 0000. 0000 1 -] -

Virwal LANs

Redundancy

QoS

»
»

»

»
Security >
»
Multicast Filtering »
»

noRes
Name Description Default
MAC address Input MAC address that match with | None
IGMP multicast group
VLAN ID Choose multicast group VLAN None
Priority Choose priority of static multicast | 7
group address lis
Port Choose IGMP multicast group’s static | None
member port

3.8 MAC Address Tables

MAC Address list features:

Check the learning MAC address
Delete unicast MAC table items
Configure switch MAC address aged time

Configure static unicast MAC address

3.8.1 Configure Static MAC

Click “MAC Address Tables-> MAC Address Tables ” in the navigation bar, then

enter “Configure Static MAC” interface.
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.(" MAC Add'ess Tables Cey s _
Administration &
Static MAC Address Table
Ports »
Virual LANS > MAC Address VLAN ID Port Priority
i , | cooe.vooe. ooot L 3V S ) L T |
Security »
QoS 4
Multicast Filtering [@
MAC Address K
Tables
Name Description Default
MAC address Input unicast MAC address None
VLAN Input host belonged VLAN 1
Port Input port matched with MAC | None
address
Priority Input priority matched with MAC | 0
address

3.8.2 Configure Dynamic MAC

Click “MAC Address Tables-> MAC Address Tables ” in the navigation bar, then

enter “Configure Dynamic MAC” interface.

Administration 3
Ports b
Virtual LANs 3
Redundancy 4
Security s
QoS »
Multicast Filtering »

»

MAC Address
Tables

I

MAC Address Tables >> MAC Address Tables
Configure Static MAC | ﬁ

MAC Address Leaming Options

Aging Time 300 (0115-3825)s
Flush Dynamic Mac Address
Upon Link Down

Clear The Dynamic MAC Address

Clear MAC Address On [ [+] | clear

Dynamic MAC Address List

Dynamic MAC Address VLAN ID Priority Port
Bleb,63a6,24ac 1 0 FE1/1

Description

Remove dynamic MAC | Choose removed dynamic MAC | None

address

address

JDK Technologies
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Aged time Input MAC address aged time 300

3.9 Network Discovery

Link Layer Discovery Protocol running on the data link layer. Through the LLDP, one
device can obtain some information of other devices which connected with (such as

the host name), even they are running different protocols on the network layer.

3.9.1 LLDP Global Remote Statistics

Click “Network Discovery-> LLDP” in the navigation bar, then enter “LLDP

Global Remote Statistics” interface.

Network Discovery >> LLDP

Ageouts 0
Inserts 1]
Drops 0
Deletes 0

This page displays the LLDP global remote statistics network discovery, including

overtime frame, insert frame, discard frame,and delete frames.

3.9.2 LLDP Neighbor Information

Click “Network Discovery-> LLDP” in the navigation bar, then enter “LLDP
Neighbor Information” interface.

Port Chassis ID  Port ID Port Descrption System Hame System Deseription System Capatibilities Nanagement addre

Manual Refreshw Refresh

This page displays the network discovery LLDP neighbor information, including port,
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classis ID, port ID, port description, system name, system description, type of

equipment, management address.

3.9.3 LLDP Statistics

Click “Network Discovery-> LLDP” in the navigation bar, then enter “LLDP

Statistics” interface

Network Discovery >> LLDP
[1157 Giobat emote Statistics [Liat seigibor Tacormstion ] [uot] |‘-
Port FramesDiscardedTotal ExFramesErrors BxFramesTotal TxFramesTotal BxPortAgeoutsTotal BxPortTLYsDiscardedTotal
FEI/1 0 1] i} 0 0 0
FE1/2 0 0 i} o i} 0
FE1/3 0 0 o 0 [} 0
FE1/4 0 0 1] 0 1] 0
FEL/S O 1] i} 0 i} 0
FE1/6 0 0 1] 1] 1] 0
FEL/T O 0 0 1] 1] 0
FEI/8 0 0 a 1] 1] 0

This page displays the LLDP statistical, including the various ports of the discarded
frames, receive error frame, received frame, send frame, frame, receive timeout

receive frame and receive TLV frame discard

394 LLDP

Click “Network Discovery-> LLDP” in the navigation bar, then enter “LLDP ”

interface.

63

www.JDKTech.com.au

JDK Technoloiies —



JDK.! '
info@jdktech.com.au

Network Discovery >> LLDP

[ LLDP Global Remote Statistics || LLDP Heighbor Information || LLDP Statistics |

Enable LLDP O
Tx Interval 130 | (5-32768)s
Hold Count 4 | (2-10)
Tx Delay 2 | (1-8192)s
Reinit Delay [2 | (2-5)s
Interval Notification 5 | (5-3600)s

Network Discovery >> LLDP

[LLDP Global Remote Statistics || LLDP Heighbor Information

Enable LLDP
Tx Interval 30 | (5-32768)s
Hold Count 4 | (2-10)
Tx Delay 2 | (1-8192)s
Reinit Delay 2 | (2-5)s
Interval Notification |5 | {5-3600) s

Port LLDP Parameters

Port Admin Status Notifications
FE1/1 |Disabled | Disabled |
FE1/2  [Disabled | Disabled v|
FE1/3  |Disabled v||Disabled |
FE1/4 |Disabled | Disabled v
FE1/S |Disabled | Disabled v
FE1/6 |Disabled | Disabled v/
FEL/T |Disabled | Disabled |
FE1/8  [Disabled w||Disabled v|

3.10 DHCP Batch Configuration

Automatically batch configuring switches via DHCP and TFTP can save time
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and lower labor cost, making management and maintenance much easier. It also
avoids manual configuration errors caused by improper operation, avoid repetitive
work and ensure configuration consistency.

DHCP refers to an IP address range controlled by server. It assigns IP address
and Subnet Mask once the clients log on.

TFTP is a simple file transfer protocol used to transfer files between remote
server and local host. TFTP protocol is based on UDP protocol. TFTP transfer request
is initiated by the client, when the TFTP client needs to download files from the server,
the client sends a request packet to the TFTP server, and receives data from the server

and sends acknowledgment.

3.10.1 DHCP Batch Configuration Preparation

1) Enable TFTP Server. Prepare switch configuration files and save effective
configuration files under TFTP directory.

2) Enable DHCP Server. Configure DHCP parameters related to TFTP Server,
sharing the IP address of TFTP Server where configuration files are saved and the
name of configuration files (.cnf); DHCP Server assigns IP address, network

mask, default gateway to switches.

3.10.2 Parameters Configuration

Click “Administration> Networks” in the navigation bar, then enter “Networks”
page. Click “DHCP Client” and “Enable Config via DHCP Server” as shown below,
then click “Apply&Save” to save configuration; swithes will automatically acquire

configuration files and upload to the system.
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- English VUsermame:
QNS Administration >> Networks | X e
m iLogout
::::m"h“ : Enable DHCP client Iﬁ =
Virtaal LANs ’ :::::: RSN [ ( Config is already acquired) I;::;
Redundancy L4 IP Address Alars
Security » Netmask Susmary
QoS ' | Gatevay
Nulticast Filtering”
BAC Address Tables P | %S ‘
Netvork Discovery * No. XS
1 8.8.88
2 202.106.0.20
0.0.0.0 ]
Save Configuration
Copricht 62001-2011 [Apply & Save )| cCancel |
Beisine Tnkied Rutrcks
AL rights reserved . .
@Iﬂstmcﬁon
® When DHCP client have been enabled, if you also enable “Enable Config via
DHCP Server”, the DHCP client will reboot.
® When DHCP client haven’t been enabled, if you enable “Enable Config via
DHCP Server”, DHCP client will be enabled automatically.
® After acquiring configuration files and uploading to switch, the switch will
automatically reboot. After reboot, “Enable Config via DHCP Server”
function will be disabled by default. When the function is enabled but the
configuration is not acquired, if switch reboots(user reboot or caused by
other reasons) the “Enable Config via DHCP Server” function is enabled by
default.
® After the configuration is acquired, switch’s IP address, subnet mask, default
gateway and DNS are still from DHCP Server, not from configuration files.
® Normally, it takes 40 seconds from enabling to configuration
acquired(exclude switch reboot time).
On switch WEB page, the description in the brackets following “Enable DHCP

Configuration” shows the satus of configuration:

1))

JDK Technologies —

“Config is already acquired": Configuration has been successfully acquired
from server. This case includes: (1) Acquiring configuration function is now

“Enabled” and configuration acquired; (2) the function is now “Disabled”,
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but the configuration is acquired after last time’s “On”.
2) “Config is not acquired yet”: Acquiring configuration function has been
enabled, but configuration is not acquired yet.

3) “Not enabled”: Acquiring configuration function is not enabled.

info@jdktech.com.au

A Attention

® Before acquiring configuration successfully, if this function or DHCP function is
disabled, the status will be switched to “Not enabled”.

® After obtaining [P address and configuration file via DHCP, the IP related
configuration parameters will be saved to configuration file, that means the
switch’s static IP address is the IP address assigned by DHCP. So it’s necessary to
modify the IP address pool of DHCP server after finish the deployment, in case to
assign a same [P address to other device.

3.11 USB Configuration auto- Backup and Restore by USB

Disc

When the switch needs to be replaced due to failure, you can back up the
configuration file from the faulty switch with a USB disk. USB disk can be used to
backup and automatically synchronize the configuration file of the switch.

When the system of the switch detects a USB disc inserted, if there is no
configuration files inside in the USB disc, the current configuration file will be
downloaded into the USB disk. Thereafter, when the configuration changes, the
system will automatically synchronize the changes to the USB disc to keep the
configuration file in the USB disk is always the latest.

Highly suggest that each switch equipped with a USB disc, this can keep the
real-time synchronizationWhen the equipment needs to be replaced due to failure,
simply insert the USB disc form the faulty switch into the replaced switch, then
reboot this switch by power on. In this process, when the configuration files in the

USB disk detected by the replaced switch, the switch will automatically download
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this configuration file form the USB disc and restore, complete seamlessly

replacement.

Appendix 1 Introduction to CLI Command
1 Help

After entering CLI, input “help”, you can know more about help information user guide.
sfe sk sk sfe sk sfe st sk sk st sk ske sk steske sk sk sk sk ske sk sie sk sk sk sk sk sk sk sk sk ste sk sk ste sk steste sk sk sieske sk sie sk sk sk ske sk sk sk sk sk sk st skeoske sk sk stk skt skt sk skoskoskoskoskoskoskeskoskekoskok

11:06:35 InSwitch > help

Input interrogation mark “?”, you can check help information at any point of command. If it
does not match successfully, then the help list is empty. You must back to input content until
system shows valid option after input “?”.

System provides two kind of help style:

1.  When you have prepared command parameter, please using entire help. For example,
“show ?”

Entire help will describe every potential parameter.

2. When you input a short parameter and want to get matching parameter list, please using
part help. For example, “show pr?”.

11:06:35 InSwitch>

s sk sk ook s ok ok ok ok ok o sk ok ok ok ok s ok ok ok ok ok s sk ok ook ok sk ok ook sk sk ok ok ok ok sk ok ok ok R sk sk sk sk ok R sk sk kR ok sk ok sk ok ok sk sk R Rk sk kK

2 User Mode

Login CLI means login user mode. Input “?”, it will show executable command.
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s s o ok o ok ok s ok stk ok o sk ok ok ok ok sk ok ok ook sk ok ok ok ok sk s sk ok ok ok s ok sk sk ok ok sk sk sk ok ok ok sk sk sk ok sk sk ok ook ok sk ok sk ok ok sk ok ok ok ok koK

11:08:44 InSwitch>

command ‘ Description ‘
Enable Switch to privileged mode
Exit Quit view/control
Help Get help command
Hostname Set hostname
Language Set operation language
Ping Ping detection
Show Show running status
Telnet Telnet login
traceroute Router detection

11:08:44 InSwitch>

sk sfe sk st sk st sk sk sieske sk sie sk sk sk sk ske sk sk sk sk sk sk skeosie sk sk ste sk skt sieske sie sk sie sk ske sk sk sk sk sk sk st sk sk sk sk sk stk sie sk skt sk st sk skoskoskokosk skoskoskoskoskokokokok

3 Privileged Mode

With user mode, input “enable ”, you will enter privileged mode, input “?”, it will show the

executable command.
sk sk s ok ok ok ok sk sk sk ok ok ok ok sk sk sk sk ok ok ok sk s sk ok ok ok sk sk sk ok ok ok sk skl ok ok ok sk sk sk sk ok ok ok sk sk sk sk ok ok ok sk sk ok ok ok skok skl ok ok okosk skosk sk ok ok skok skosk ok

11:20:07 InSwitch>enable
Please input password:
11:20:09 InSwitch#

Executable command:

command ‘ Description ‘
Configure Enter configure mode
Copy Copy files
Default Recover appointed parameter as default
Disable Quit privileged mode
Erase Clear files
Exit Quit view/control
Help Get help command
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Hostname Set hostname

Language Set operation language

No Cancel setting of appointed parameter
Password Set password

Ping Ping detection

reboot Reboot system

Show Show running status

Telnet Telnet login

traceroute Route detection

Username Set username and password

11:20:10 InSwitch#

sfe sfe sk st sk stesie sk sk sieske sk sie sk sk sk sk ske sk sk sk sk sk sk skeoste sk sk ste sk skt steske sie sk sk sk sk sk sk sk sk sk sk sk sk sk sk skeoske stk sk sk kst sk sieoskoskoskoskokokoskoskoskoskoskok kol

4 Configure Mode

With privileged mode, input “configure terminal”, enter configure mode, then input “?”, it will
show executable command.
st sfe s ot sk st s o sk st sk ot sk st s st s st s st s stk ot s o s o sk s st sk s st s ok s ok sk s s sk ok s st sk s skt skt skt skt skt skt skt sk g skofesk gk ok
11:21:10 InSwitch# configure terminal
11:21:11 InSwitch config#

command ‘ Description ‘
Alarm Set warn
Clear Clear information or configuration
Clock Set system time
Copy Copy files
Crypto Set SSH parameter
Default Recover appointed parameter as default
Disable Quit privileged mode
Email Set email parameter
Erase Clear files
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Exit Quit view/control

G8032 G8032 ring network protected protocol
gmrp GMRP configuration
help Get help command
Hostname Set hostname

Iec61850 IEC 61850

interface Enter port mode

ip Overall IP configuration
language Set operation language
lacp LACP setting

1ldp LLDP protocol

log Remote log server

mac MAC address setting
monitor Port moniter

no Cancel setting of appointed parameter
password Set password

ping Ping detection
port-channel TRUNK setting

qos QoS

reboot Reboot system

rmon Remote moniter

relay Set relay parameter

show Show running status
snmp-server Modify SNMP parameter
sntp-client Set network time server

spanning-tree

Spanning-tree protocol

telnet

telnet login

traceroute

Route detection
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temperature Set temperature for warning limitation
username Set username and password
vlan VLAN setting

11:21:14 InSwitch config#

s sk sk o ok ok ok ok ok ok o sk ok ok ook s ok ok KoK s ok ok ok ot ok s ok ook ook sk ok ok ok ok ok s sk stk ok ko sk ok sk ok ok sk ok ok ok ks sk ok ook o sk ok sk ok ok ok sk sk sk ok ok ok

5 Port mode

With privileged mode, input “interface fastehernet 1/1”, enter fastethernet 1/1 port mode, then
input “?”, it will show executable command.
sfe sk sk sk sfe sfe st sk sk st sk ske st skeske sk sk sk ske sk sk sie sk sk sk sk sk sk sk sk sk ste sk sk ste sk steste s sk sieske sk sie st sk sk sk sk sk sk sk sk sk sk skeoske sk sk stk skt skt sk skoskoskokoskoskoskoskoskekokok
11:23:02 InSwitch config# interface fastethernet 1/1
11:23:02 InSwitch-FE-1/1#
11:23:46 InSwitch-FE-1/1#

Port configuration command:

command ‘ Description ‘
block Block flow of port
cfm Link connection detect
channel-group Ethernet connection pond setting
default Recover appointed parameter as default
description Add interface description
discard Import frame discard
duplex Setting duplex-mode
exit Quit view/control
Flow-control Flow control
help Get help command
lacp LACP port configuration
learn MAC address learning
lldp Setting LLDP
no Cancel setting of appointed parameter
Port-security Port security
protected Set port protection
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qos QoS

rate-limit Limit rate

rmon Remote moniter

show Show running status

shutdown Port off

spanning-tree Spanning-tree protocol

speed Set port rate

storm-control Control storm

vlan-tunnel VLAN transparent transmission

11:23:47 InSwitch-FE-1/1#

sk sfe sk st sk st sk sk skeske sk sie sk sk sk sk ske sk sk sk sk sk sk skeosie sk sk ste sk skt steske sie sk sie sk ske sk ske sk sk sk sk sk sk sk st skeoske stk sie sk skt sk sieoskoskoskoskokokoskoskoskoskoskokokokok

6 VLAN Mode

With privileged mode, input “VLAN 1007, enter VLAN mode, then input “?”, it will show

executable command.

s sk sk o ok ok ok ok ok ok o s ok ok ook ok ok ok Kok R sk ok sk ok ok ok s sk sk ok ok ok sk ok ok ok ok ok s sk ook ok sk sk ok ko R sk ok sk ok ks sk ok ok o sk sk sk sk ok R sk sk ok K ok ok

11:25:05 InSwitch config# vlan 100
11:25:06 InSwitch-vlan-100#

VLAN configuration command:

command ‘ Description ‘
default Recover appointed parameter as default
exit Quit view/control
help Get help command
Iec61850 IEC 61850
member Setting VLAN member
name Add VLAN name
no Cancel setting appointed parameter
priority Setting VLAN priority
show Show running status

11:26:59 InSwitch-vlan-100#

s sk sk o ok ok ok ok ok ok o sk ok ok o ok s o ok ok ook sk ok oKk ok sk ok ook ok sk ok sk ok ok sk ok ook ok sk s sk ok ok ok sk sk ok ok sk sk sk ok ok sk sk ok
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7 Ring Instance Configuration Mode

With privileged mode, input “g8032 107, enter ring instance configuration mode, then input “?”, it
will show executable command.
sk sfe sk st sk st sk sk sk sk sk sie sk sk sk sk sk sk sk sk sk sk st skeosie sk sk ste sk skeske sieske sk sk sk sk ske sk sk sk sk sk skeoske sk skeoste stk steskeoskeoskeoskoskoskoskoskeskoskosk
11:28:56 InSwitch config#
11:29:05 InSwitch config# g8032 10
G8032 Instance id is 10, is ok
11:29:05 InSwitch-InRing-10#

Get help command

You can input “?” to get help anytime during inputting command

command Description ‘
control-vlan Set ring network control vlan
default Recover appointed parameter as default
enable G8032 instance
exit Quit view/control
help Get help command
no Cancel setting appointed parameter
node-type Set node type
port Set ring network port
ring-type Set ring type
show Show running status
service-vlan Set ring netword data vlan

11:29:07 InSwitch-InRing-10#

sk sfe sk st sk stk sk sk sk sk sk sie sk sk sk sk sk sk sk sk sk sk sk skeoske sk sk ste sk skesie sk ske sk sie sk sk ske sk sk sk sk sk skeoske sk steoske stk steskeoskeoskoskoskoskoskoskoskoskosk

& Attention:

After one ring instance worked, the instance is running, it cannot enter

configuration mode.
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Appendix 2 Ring Network Configuration Example

First, there are two data path in the ring network, including the data path of
transmitted ring control message and data path of transmitted business data. As a
result, before configuring ring, you need to establish data path, that is configured
VLAN. Then, there are three different roles of nodes in the ring, respectively owner

node, neighbor nodes and normal nodes.

® Owner node: when the ring network link failure, open backup link in time and
notify the other nodes; after a link back to normal in the ring network, please
block backup link.

® Neighbor node: when the ring network link failure, open backup link in time;
after the ring network link recovery, waiting for a confirmation sent by owner
node that link is normal, then block backup link.

® Normal node: when the ring network link failure, notify other nodes.

In the ring network, you must configure an owner node, however, neighbor node
configuration is not required. Finally, after the end of each node configured, pay
attention that the left port is backup link port as default for owner node and neighbor
node, so you need to ring the two ports connected to the left.

Take 4 ISM2009D industrial Ethernet switch as example. The configuration step as

below:

Step 1: Configure Data Path
Click “Virtual LANs[] Static Virtual LAN ” in the navigation bar, then enter “VLAN

configure” interface.

In each switch, add tagged port FE1/7 and FE1/8 into VLAN 2,3.4,5, then click apply.

&)

L Virtual LANs >> Static Virtual LANs

e e
Administration L4

R VLAN ID Priority Name FE1/1 FE1/2 FE1/3 FE1/4 FE1/5 FE1/6 FE1/7
Ports 1 0 YLANDOO! untagged untagged untagged untagged untagged untagged untagge
Vintual LANs 4 0 [+] none  [v] none  [v][none  [v][none [v] none [v][none  [v] none
Redundancy i
Security »
Qo3 ' Apply & Save|[ Cancel
Multicast Filtering  »
MAC Address >
Tables
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-
i:‘fam R >> BB RUR R
VinRE|
) ’
#®o » vlan 5 ? 273 FEL/1 FE1/2 FE1/3 FE1/4 FE1/§ FEI/6 FE1/T FE1/8 FE1/9
ERE P » 1 0 VL0001 umtagged  untagged  untagged  witagged  untagged  umtagged  wntagged  untagged  untagged
3 2 0 VLAKOO002 tagged tagged
T 3 0 VLANQOOZ tagged tagged
%L » 4 0 VLANOO0D4 tagged tagged
RENR » 5 0 VLAKOQOS tagged tagged
- ) [0 ™[ |[pone @l [none i [pone @ [mone 8 [mone S [pone ] [oome 8 (poe 80 [cone )
naciEE ,

Step 2: Configure Ring instance

The 4 industrial Ethernet switch should be configured as node’s role. You need
configure one switch with owner node, one switch with neighbor node and two
switches with normal node. Take owner node as example, other nodes’ configuration

are same like owner node.

1. Set instance ID, range from 1 to 10. Set 1 as instance ID here.

Advanced Config

Instance  Ring Type  Major Ring ID Node Type  Gomere! Service VLAN Left Port  Right Port
_ T oh ol :

2. Choose ring type as major ring.

Advanced Config

'"s!ﬁ;'“ Ring Type Major Ring ID Node Type C\‘,’{'}\'ﬁl Service VLAN Left Port  Right Port
1 Major Ring [+] | [=] [ I [~] -
3. Choose node type as major ring.
Advanced Config
Instance Ri . Control
D ng Type Major Ring ID Mode Type VLAN Service VLAN Left Port Right Port
1 Major Ring |:| Owmer :I I E| [ } vl :

4. Choose control VLAN, set 2 as control VLAN here
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Advanced Config

Instance  Ring Type  Major Ring ID Node Type  Goifel Service VLAN Left Port  Right Port
! Major Ring [~]] |[owner [~] (-] | [ ][ [~]

5. Configure data VLAN, input VLAN that configured in step 1. Set data VLAN

1, 3, 4, 5, the number was separated by comma.

Advanced Config

Instance  Ring Tye  Major Ring ID Node Type o' Service VLAN Left Port  Right Port
! Major Ring [v][  Jlowmer [v][t  []L34H I | I

6. Configure left port. Choose one trillion optical port FE1/7 as left port.

AT,

Advanced Config

Instance  Ring Type  Major Ring ID Node Type GOMire! Service VLAN Left Port  Right Port
1 Major Ring [+] | |lowner [+] (2 [¥] 1.3.4,5 FEL/T [+] | [+

7. Configure right port. Choose one trillion optical port FE1/8 as right port.

Advanced Config

Instance  Ring Type  Major Ring ID Node Type  GoMirel Service VLAN Left Port  Right Port
1 Major Ring :l [Owner l:i 2 : 1,3,4,5 n n

8. Click “add”, then click “apply and save”, configure owner node successfully.

Advanced Config

Instance  Ring Type  Major Ring ID Node Type  Gomire! Service VLAN Left Port Right Port
1 Major Ring Owner 2 1,345 FE1/7 FE1/8

9. After configuration was finished, click “Ring Instance Status” to see ring

network status.
o]

Lo -] Redundancy >> G.8032v2 ERPS

e
Administration " m R Major R Nod RPL Left Ring P Right Ring P

nstance ing ajor Ring ode o ng Ports gl ing Ports
Ports > D Type D [Tpa i iearconneEton ns il Nodetblatie (Status) (Status)
Virtual LANs » 1 ’g;‘;' 0 Owner No FEVT PIEEEON e a@locked) FE1/8(Blocked)
Redundancy r
Secury ? ol Roficesh(s] [ Rofrosh |
QoS 1
Multicast Filtering >
MAC Address >
Tables
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Step 3: Connect Ring Network

After 4 industrial Ethernet switch have been configured, connect them to a ring. First,
connect left port of owner node with left port of neighbor node. Secondly, make the

other switches connect to a ring. The other link have no ring port limitation.

Appendix 3 Troubleshooting

FAQ Methods

Power indicator doesn’t light (1) Please check the power line if connected correctly.

(2) Please check the power line plug is plugged in tight, no loose

Port indicator doesn’t light (1) Please check if the cable and switch port connect tightly, there are
no loose

(2) Two cables are respectively inserted into the two port of the switch,
if the two indicators that two Ethernet prots corresponding to light, that
means cable is normal; otherwise the cable may be a problem, please

replace the cables and try again

Can’t access to switch by WEB (1) Using the ping command to check network
® Ping 127.0.0.1 to check the TCP/IP if is installed
®  Ping the defautlt IP address of switch, to check if the PC can
communicate with switch.
(2) Ensure the PC’s IP is in a same network segment with switch
(3) check the Web browser is set up a proxy server or dial-up

connection, if any, please cancel
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Appendix 4 Glossary

Abbreviations Full Name Meaning

100Mbit/s baseband Ethernet standard, using the type 5 twisted
100Base-TX 100Base-TX pair to connect, can provide the maximumtransmission rate of

100Mbit/s

100Mbit/s baseband Ethernet standard, using the type 3/4/5
10Base-T 10Base-T twisted pair to connect, can provide the maximumtransmission

rate of 10Mbit/s

The Ping command is a diagnostic tool used to test the

machineand other computers on the
Packet Internet
Ping network can communicate. The Ping command message to the
Grope
specified computer, if the computerreceives a message will return

aresponse message

Quality of service (Quality of Service) is used as a technique to

solve the network delay and congestion. When the network

Quality of
QoS overload or congestion, QoS can ensure the important traffic
Service
without delay or discarded, while ensuring the efficient
operation of network.
For standard plug connected with Ethernet switches, hubs,
RJ-45 RJ-45 routers and other equipment. Straight cable and a crossover

cable typically use this joint
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Simple Network SNMP is the communication rules between the NMS and agent in
SNMP Management the network, it defines a series of messages, and grammar, is
Protocol used to realize the access and management of NMS to agent

A method used to access remote host’s interactive program
Telnet Telnet based on characters. Telnet

Allows users to remotely log on and manage device

Wide area network (Wide Area Network) is a data

Wide Area
WAN communication network covering the geographic range is
Network
relatively wide, such as the Internet
LAN (Local Area Network) generally refers to the internal
Local Area
LAN network, such as the family network, small and medium-sized
Network

enterprise internal network etc.
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Support

In case you have problems with the installation and use, please address them to us by e-mail:

support@inhandnetworks.com.

81

www.JDKTech.com.au

JDK Technoloiies —



